Pages deploy not updating from artifacts with custom domain

Hi all,

I’m deploying a website using GL pages with a custom domain. The webpages won’t update for some reason. I got everything setup initially but now a week later it won’t update anymore. I haven’t made any changes sense I first created the site. So this is quite puzzling.

This is from the issue I was writing. Thought while writing it that this might be a miss configuration on my part. Any suggestions would be much appreciated.


Updating a gitlab pages cite isn’t working. When I push a commit to gitlab CI runs and succeeds then pages updates the site and it reports as a success. But the webpage isn’t updated.

This isn’t my first time using GL pages. It is my first time using it with a custom domain. And this is the first time I’m seeing this. An old forum page that looks like it’s similar behavior Gitlab pages won't update site?

Steps to reproduce

  1. Clone GitHub - okkur/syna-start: Clonable starter repository for a Syna theme based website
  2. Configure the demo site with your custom domain.
  3. Commit this as your .gitlab-ci.yml file.

  - apk add --update --no-cache git


  - hugo
    - public
  - master

  1. Attach a custom domain to it using the web portal.
  2. Allow Gitlab CI to build and publish your website.
  3. Now update the site through a git commit.

CI will build properly and pages will report as a success but your webpage will not update.

Hi @sleuth

This seems very odd! My first guess would be that it’s an issue with DNS propagation (*). A few questions:

  • If you go to the latest pipeline artifact in your master branch, does it contain the “new” site?
  • If you visit your site via its URL, rather than your custom domain, does it contain the “new” site?
  • What if you open dev tools in your browser and turn off the cache?
  • If you visit your custom domain with the cache off, or via an incognito window, do you see the “new” site?



(*) You know what I mean

The artifact has the new site.
Incognito windows still get the old site.
When using the gitlab provided url it’s correct. Do to how hugo works I had to make a push to change the baseurl so it’s a different CI build. I don’t think that could cause it to change from old to new though.

Everything was tested with new incognito windows.

So, I think this is not a GitLab problem but something to do with the DNS on your site. Do you use Cloudflare or something similar? It might be worth a look.

Otherwise, it should update eventually…

Could you explain why it could be DNS?
These changes are 6 days old so it shouldn’t be a propagation problem.

Turns out that the site got moved to a different web host without my knowledge. Sorry for wasting your time.

1 Like

Well, at least you solved the mystery!

1 Like