Pages not showing up, likely due to project rename?

Hello! I set up pages on First I started with a project that had unrelated name (and broken CI, let’s be honest who can get that correct on the first try?), but then I found out that by naming it <username> I can get the pages on <username> instead of <username><projectname> which I prefer. So I changed both the path and name of the project accordingly.

The CI now shows both pages and pages:deploy as successful. Navigating to settings/pages says Your pages are served under:, however clicking the link renders a 404 page instead of the pages.

I’ve waited more than the 30mins it should take and tried rerunning the CI pipelines but no luck. I’ve also tried clearing runner cache before rerunning the pipeline in case something didn’t refresh properly after the rename and waited another hour, but the pages are still not shown.

Does anyone have any idea what’s up? Is it a bug that I should submit, or are there more caches involved and due to the rename I should wait a day (which would be ridiculous) till the pages show up?

EDIT: I tried removing the pages in settings and rerunning the pipelines and deleting the project and recreating it. Neither helped and the URL is still returning 404.

it seems Gitlab Pages works fine, and you don’t have a index.html file, so there is a problem in the build of the website.

If you open the job on Gitlab, on the right there is a “Browse” to see the name of the files created. You need to have an index.html inside the public directory


Thank you for looking into it! I guess I expected a different error message to be shown, to differentiate broken pages from ones that really don’t exist. Fixing the pages is secondary to checking if they even deployed :smiley: