Pipeline stuck in pending state

Hi everyone,

I’ve been using gitlab CI for a little less than a month now, and unfortunately I’ve reached my 2000 minutes quota. The interface was greeting me with a “no more credit” message, and all my pipelines were automatically rejected ( which is normal I guess :wink: ).

My project belongs to a group, and we are two owners of this group. The other owner bought 1000 more minutes and now the messages disappeared and the pipeline goes into pending status, as if everything went back to normal.

The problem is that all pipelines stay in pending mode forever. I started one yesterday and it was still in pending mode this morning,

What I’m doing wrong? Is there a delay before activation of those credits? Or is it a bug with Gitlab CE?

i have the same issue, did you fix it? is annoying that even paying for minutes you dont have a minimum support from them :\

Hi,

I’m glad you raised the same issue because I had no reply from Gitlab. I have no clue on how to solve this problem. If you get any response or hint on how to repair that feel free to share :innocent:

We have the exact same issue, so I’m following this!

Update!

Just filed a support request on https://support.gitlab.com/hc/en-us/requests/new?ticket_form_id=334447 and within minutes the pipelines started running again.
No message from them yet, but I’m sure someone just looked at it and fixed it from their side.

This behavior aligns with a known issue (GitLab Internal only) that we are investigating. A fix is scheduled for a coming release 12.1.

For now, please raise a ticket with the GitLab.com support team.

3 Likes

Cool. Got your email saying the same thing too.
Thanks for the quick support!

1 Like

Same here,

After opening a ticket via https://support.gitlab.com/hc/en-us the problem was solved within minutes.

Awesome reactivity! Thank you so much!

1 Like

Having this problem now. Submitted ticket to Gitlab as suggested.

Very frustrating. It would be nice if GitLab could show when/how it is making decisions about starting Pipelines and Jobs within pipelines. Now it is just a black box.

1 Like