Pipelines cannot be created for specific users

Describe your question in as much detail as possible:
I am using a self-hosted Gitlab instance (currently v14.10.2). It is used by multiple developers.
Some of them (myself included) cannot create pipelines (for new projects) or run any existing (for old projects), even though they could in the past.

  • What are you seeing, and how does that differ from what you expect to see?
    I noticed this issue after a job got stuck while running, and remained stuck for a few days (until then pipelines were created normally, after each push) . Job could not be removed/stopped and new jobs/pipelines stopped being created. I deleted the project and after that whenever I pushed to any project (new/old) and any branch (remotely or not) pipelines are not created.

Furthermore, event though I create a .gitlab-ci.yml file when I enter the pipelines section it displays the greeting message, prompting me to create a .gitlab-ci.yml file (it is as if ,the existing one is not detected)

This affects several accounts. However, a few users can use the pipelines features (in the same gitlab instance).

  • Consider including screenshots, error messages, and/or other helpful visuals

  • Add the CI configuration from .gitlab-ci.yml and other configuration if relevant (e.g. docker-compose.yml)
    I am using the default .gitlab-ci.yml config for a newly created project

  • What troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?
    I have tried changing the gitlab-ci file config, enabling disabling runners, auto devops and pipeline features, creating different projects, in different groups and from different users. I have also tried connecting from different PCs (if it was a network issue).

Thanks for taking the time to be thorough in your request, it really helps! :blush: