Repositories disappearing suddenly


#1

Seemingly overnight, some repositories went missing in our team. The project is still visible in the overview but when opening it it shows No repository The repository for this project does not exist.

This happened to two (large) repositories that were in use for quite some time and (as far as anyone can tell) nothing changed on our end. What can we do to fix this besides resubmitting all the code from the working copies. This could be a work-around but I am quite concerned about the security/availability of our repositories now.


#2

We’ve seen the exact same issue. Disappeared repository for no obvious reasons all of a sudden. Merge Requests and Pipeline etc. are still there although the links might not be available from the menu. But if you type them in the address bar, they appear.


#3

Same for me, repository dissapeared just 1h ago. 1h ago i was able to push stuff and now its gone :-(.
Any ideas already? seems to be a general thing.

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree fetch origin
remote: A repository for this project does not exist yet.
fatal: unable to access ‘https://gitlab.com/urbansyncDev/net.urbansync.cloud.git/’: The requested URL returned error: 403
Completed with errors, see above

“Funny” side effect, i just wanted to go live with my api application and upload app to appstore. Yeah, such things always happens


#4

Same here. One of our private repository just disappeared from webpage and got a 403 error while fetching. Tried what @fzumstein mentioned but no lucks. PLEASE RECOVER IT ASAP!


#5

support told me that this was a caching issue (at least for my case). They fixed it on their side. would suggest to contact them to handle it accordingly

best markus


#6

Happened to our repository as well: https://gitlab.com/noosfero/noosfero


#7

In the end, I just had to click the left button “create new bare repository” (don’t remember the exact wording) and it was all back and working.


#8

Same for me. One of my private repositories disappeared suddenly.


#9

Check your username path, mine have all ‘disapperead’ but my paths now have an extra ‘0’ in them https://gitlab.com/user0name/project/repo I have emailed support as it’s not likely something we can fix