Repository Size Limit on Gitlab.com

Hello there,

Gitlab user since few years, I run into a new issue today.
While making a PR on one of the project I’m working on (a private repository on Gitlab.com), I run into this message:

The size of this repository (9.8 GB) exceeds the limit of 9.8 GB by 18 MB

The message is quite explicit, OK no problem I will try to take care of it and reduce the size of the repo, it’s a quite old project imported from backlog so there are room for improvement (14k commit over 5 years)

So this afternoon I spend some time with BFG and this Guide (https://docs.gitlab.com/ee/user/project/repository/reducing_the_repo_size_using_git.html)
And by removing old assets from the history, I managed to get pretty good results (9.8GB -> 5GB).

> git count-objects -vH
count: 0
size: 0 bytes
in-pack: 147677
packs: 1
size-pack: 5.05 GiB
prune-packable: 0
garbage: 0
size-garbage: 0 bytes

But the problem is now to push those modification on the remote repo. Whatever I try, it fails with the same size limit error.

> git push
Enumerating objects: 147677, done.
Counting objects: 100% (147677/147677), done.
Delta compression using up to 12 threads
Compressing objects: 100% (41427/41427), done.
Writing objects: 100% (147677/147677), 5.04 GiB | 5.95 MiB/s, done.
Total 147677 (delta 105905), reused 147677 (delta 105905)
remote: Resolving deltas: 100% (105905/105905), done.
remote: Checking connectivity: 135742, done.
remote: GitLab: Your push to this repository would cause it to exceed the size limit of 9.8 GB so it has been rejected. Please contact your GitLab administrator for more information.

If I was on my gitlab instance, I know how to change the settings and solve this issue, but on Gitlab.com I’m a bit stuck and I can’t find any option to help me in the settings. And creating a new repo does not sounds like a solution because we already have issues, wiki, tags & releases

So for the moment I have an unusable repository, Any idea how to solve this situation ?

P.S. OK apparently there were discussion about this few month ago https://gitlab.com/gitlab-com/gl-infra/infrastructure/issues/4420#note_84380019

OK not getting any answer here, I had to move forward so I pushed the BFG result to a new repo and ask my team to fork and clone this new project.
Migrated the wiki, release and CI settings.

At the end, it sounds like a waste of resource for gitlab.com (there is now 2 project) and as a user it’s a pain to migrate repo … but at least we can work again.

Hey @kefniark, our apologies that you needed to use a workaround to get that sorted. If you’d like to continue using the original repository we can get this sorted out for you by temporarily removing the limit so that the size reduction changes can be pushed.

Please contact us directly and we’d be happy to help.