Service desk create issue and at the same time raise "We couldn't find the project."

Hi there !

I’m stuck with configuring service desk on our Gitlab CE production server.

When I send an email using provided service desk email address for a project:

  • the issue is created
  • I receive an acknowledge about issue create
  • and I receive an error email with “We couldn’t find the project. Please check if there’s any typo.” inside

I can’t find this kind of error/behaviour in the issues of gitlab. I don’t know where to look to find logging or something helpful.

Do you have any clues ?

Extract from gitlab-rake gitlab:env:info

System information System: Debian 10
GitLab information Version: 15.1.1 Revision: 35925db62b6
Using LDAP: yes
Using Omniauth: yes
Omniauth Providers:

Are you using a suffix? This issue might help with a potential solution:

Thank you for pointing me this, but I do not use suffix for email address.

Here is an excerpt of the gitlab.rb for email configuration and service desk:

"gitlab_email_from": "gitlab@*******",
"gitlab_email_reply_to": "*******",
"incoming_email_enabled": true,
"incoming_email_address": "gitlab-%{key}@*******",
"incoming_email_email": "*******",
"incoming_email_password": "*******",
"incoming_email_host": "imap.*******",
"incoming_email_port": 993,
"incoming_email_ssl": true,
"incoming_email_log_file": "/var/log/gitlab/mailroom/mail_room_json.log",
"service_desk_email_enabled": true,
"incoming_email_expunge_deleted": false,

I try with and without expunge of the incoming email using incoming_email_expunge_deleted parameter but the problem is still here.

It’s quiet annoying because it works (create issue and sending acknowledge email) … but it does not fully work (sending an error notification email). So today I can not use it in production.

If it is something relevant, gitlab is installed using omnibus. I have not change the configuration for a long time (since version 12 of gitlab), just adding the service desk now.
I have another server for testing, with a fresh install of the same gitlab version, with the same configuration and everything is working fine with this one.

My testing server wasn’t exactly using the smae configuration as the production : no HTTPS and no proxy.

Now I have set up the proxy and HTTPS, and I can reproduce the same error. I will try removing HTTPS than proxy to figure if it is one of those that could trigger the error.

All right I found it, and it has nothing to deal with gitlab config.

There were 2 gitlab servers accepting service desk email from the same mailbox. So one say “ok I create issue and notify all is fine” and the other “What is that project ? Send error notification”.

Anyway : thank you iwalker for helping :wink:

1 Like

Hmm yeah :slight_smile: might want to use separate mailboxes for multiple Gitlab instances so that it doesn’t get confused what email belongs where. Glad it’s solved though. Sorry couldn’t help much.

I have a similar issue but mine is solely the rejection mail I get. And this happens for just internal users, our external users are able to send in mails and it gets registered on Service Desk.
I would appreciate some insight.

Please see below for my configuration:

gitlab_rails[‘service_desk_address’] = ‘’

gitlab_rails[‘smtp_enable’] = true
gitlab_rails[‘smtp_address’] = ‘
gitlab_rails[‘smtp_port’] = 587
gitlab_rails[‘smtp_user_name’] = ‘helpdesk’
gitlab_rails[‘smtp_password’] = ‘password’
gitlab_rails[‘smtp_authentication’] = ‘login’
gitlab_rails[‘smtp_enable_starttls_auto’] = true

gitlab_rails[‘smtp_tls_cert_path’] = ‘/home/oo_oo/******-com-chain.pem’

gitlab_rails[‘incoming_email_enabled’] = true

gitlab_rails[‘incoming_email_address’] = “helpdesk-%{key}
gitlab_rails[‘service_desk_email_address’] = “helpdesk-%{key}

gitlab_rails[‘incoming_email_email’] = “helpdesk”
gitlab_rails[‘incoming_email_password’] = ‘password’

gitlab_rails[‘incoming_email_host’] = “
gitlab_rails[‘incoming_email_port’] = 993
gitlab_rails[‘incoming_email_ssl’] = true

gitlab_rails[‘incoming_email_expunge_deleted’] = true
gitlab_rails[‘incoming_email_start_tls’] = false
gitlab_rails[‘incoming_email_mailbox_name’] = “Inbox”
gitlab_rails[‘incoming_email_idle_timeout’] = 60

gitlab_rails[‘service_desk_email_log_file’] = “/var/log/gitlab/mailroom/mail_room_json.log”

gitlab_rails[‘incoming_email_delivery_method’] = “sidekiq”
gitlab_rails[‘service_desk_email_delivery_method’] = “sidekiq”

gitlab_rails[‘gitlab_email_from’] = ‘’
gitlab_rails[‘gitlab_email_reply_to’] = ‘helpdesk-%{key}