The project is still being deleted. Please try again later

I have delete project few hours ago and I want to create a new one with the exactly same name as deleted project. Gitlab give me this error:

The project is still being deleted. Please try again later.

It tooks too long for my opinion. Should I wait longer or is this some kind of bug?
Thanks for help.

2 Likes

Same here …
deleted a Project and want to create a new one with the same Name.

Hope there is a solution.

I’m also experiencing this problem on GitLab.com. Maybe the delete queue got stuck?

Hi, I’m getting the very same error. It’s been ~16 hours and I still can’t create a project with the same name as the project I previously deleted (it seems to be deleted as it isn’t shown in my projects).

What should I do? Thanks
Petr

I am experiencing the same issue. I deleted a private group repo 2 days ago and have been unable to reclaim the name. I was able to reproduce it with the exact same repo under my personal namespace.

Hi, I created an issue and tried to contact gitlab team via all channels I found, but nobody has replied yet. It’s been more than 2 days now :-/ This is really critical, I’m seriously considering paying github :frowning:

I was moving away from GitHub and this was a trial before committing to the switch. I hope it’s resolved soon. I can’t even trial this since I can’t import my repo again.

Pretty same here… we are deciding where to host our code and gitlab is the only one that doesn’t work :frowning:

1 Like

I’m having this issue on a self-hosted gitlab community, first occurrence that I noticed was last Thursday 2/23… we are evaluating upgrading to enterprise.

Same with me, I deleted the repo 4 days agp

Same here… it takes very long. I am hoping it actually gets deleted eventually?

Hi all I am trying to create a new fork by deleting existing on on gitlab.com from last 4 days I am facing the same error

Has anyone found a solution yet? I deleted a project a week ago and I’m still unable to recreate it using the same name (“The project is still being deleted. Please try again later.”).

Hi, i+I’m having the same issue, for weeks, I finally had to rename the project. :sweat:

Same problem for me, Its been almost 2 weeks i am still getting this error.
Its really frustrating. .

same problem. Deleted a project and attempted to make a new project with the same name.

Just to let you know: 2 weeks after deletion, I finally managed to re-create my project with the same name. Maybe it’s just a matter of time then.