Today repo view of main content broke in Palemoon/Waterfox

Hello Gitlab,

I use your site everyday, my browser settings have not changed.

12 hours ago, I pushed some updates to a repo and everyhing was fine, I was able to see branches being tagged as “merged” into a develop branch.

Today, a browser refresh showed everything okay, but some time later, the main content area is now blank in my Palemoon 28.13.0 under Windows 10 x64. Palemoon has not been updated in some months.

I see the top header, and the left side menu with icons (as usual).

However, if I hover over a left side icon, its related drop down icons are missing, if I click, the main content is missing. All my many opened browser tabs to frequently view GitLab content have turned blank.

This issue is not repo specific, it happens with any repo that I visit.

Link image to demonstrate …

I rebooted Windows to check my sanity has not left me. I deleted cookies, forcing a log out, and then logged back in to the site, no success.

I cannot see any JS errors in the Palemoon “Console” view.

If I run the Palemoon “Inspector” function, I can see a div class="alert wrapper" is set to display:none - if I disable this, textual content becomes visible.

My conclusion is that you have put an update out to production and that update is broken under Palemoon. I tested with Waterfox Classic - same thing :frowning:

Please can you fix this.

Best Regards

1 Like

Can confirm this. Same thing here, same version of Palemoon.

Confirm with (Firefox fork) PaleMoon 28.13 on Linux. Broke somewhere around 9am BST 23 Sep. Made new repo fine, pushed code, and was reviewing some files and suddenly the web UI “died” only giving some of the UI elements (top bar, sometimes partial sidebar) and no content.

I just logged in here to confirm. I just opened GitLab to check some issues in F-Droid repos and nothing worked.

Seems to be working well right now again.