Unable to create MR in free tier due to "Approval rules users is invalid"

Unable to create MR due to “Approval rules users is invalid”, despite this option is not enabled (free tier)

Thanks for taking the time to be thorough in your request, it really helps! :blush:

1 Like

Approval rules are indeed available in Free tier. From the error it seems the ones in the project are invalid.

@balonik thanks for the reply
the thing is we are not using rules so far, so yesterday it was ok, however today it causes problems

It’s not easy to provide quick fix. It depends if you are on GitLab Saas, running your own instance.
If you are on GitLab SaaS I’d check the repository settings for Merge requests first, maybe someone enabled something.
If you are on self-hosted instance you can check the same. And if you are not admin of the instance I suggest to check with your Gitlab admin team.

Have the same error. Doc says, that approval rules are available only in Premium: Merge request approval rules | GitLab
Also we don’t have Merge request approvals section in settings, even a member with Owner role doesn’t see it

@Vlad-Topilskiy agree

I encounter the same problem here. Using the free SaaS gitlab.com, never have ever used approval rules, and was able to create MR just a few days ago. But, now, we are stuck and cannot create any MR anymore.

I tried again and I could successfully create my MR !

Solved by deleting very old approval rules through gitlab api: Merge request approvals API | GitLab

1 Like

@Chcap me as well, looks like some internal error

Hi all! Thanks for reporting this. We’ve received a few other reports internally around the same time and wanted to check to see if anyone else is currently experiencing this or unable to work around it.

It’s possible the issue may have been transient if retrying worked.

This MR has raised suspicions but just gathering feedback as we investigate and consult with our development team. Thanks!