User validation required, even after successfully entering credit card

I’m new to GitLab CI. When I tried adding a .gitlab-ci.yml file to my repo, I get an error that user validation is required: Pipeline · Isaac Petersen / Bookdown Gitlab · GitLab

However, I have entered my credit card information multiple times. Each time I enter it, it says:

“User successfully validated. Your user account has been successfully validated. You can now use free pipeline minutes.”

But then I refresh the page, and it still says “User Validation Required”

5 Likes

Same issue here. I’ve tried multiple cards and a transaction for $1 goes through, which is immediately reverted.

Hello,

Same thing for my team with our most recent users (older users have no problems triggering pipelines), i’m interested in suggestions to solve the issue.

I have the same

Yup same issue here! Endless “User Validation Required” but commits are still being failed.

We’ve solved it in our case. I think there were two problems:

  1. I could not validate someone else’s account in my organisation (despite the banner showing up for me on a pipeline they triggered). They had to do the validation themselves.
  2. There is a bug where the banner displays if a pipeline fails because the user was not validated at the time. It doesn’t check whether the user is now validated (so it would still show if you validate and refresh the page). See this issue: Crypto Abuse - Once a user validates a card we should make it easy to pickup where they left off (#331983) · Issues · GitLab.org / GitLab · GitLab

The same PROBLEM, please HELP!

I have the same problem - we have a group that has been running for a while and taking advantage of both the 2000 free minutes as well as using our own runners. I’ve added a new user to the group and they can’t run pipelines - when I push to the repo, the pipelines run fine, but when they push to the repo, the pipeline fail with a request for them to verify themselves with a credit card.

Obviously I don’t want my developer to put their own personal credit card into Gitlab when they do work for my company, but I can’t figure out how to authorize them.

This is the commit that caused this behavior change: Prevent creating pipeline on free and trial plans without CC info (3f856b60) · Commits · GitLab.org / GitLab · GitLab, it is by @fabiopitino

1 Like

Yes, I’m having the same issue- when I try to validate my card number, after clicking validate, the credit card fields dissapear but no progress is made.

Any progress on this ?

Can you try again? We fixed some issues with the window not showing errors if the credit card was not validated properly.

I have a similar problem (new gitlab user contributed to our FOSS project with a MR, pipeline for this MR fails due to the user not being validated) and found this thread via a web search. In case we can’t find a solution, I’ll open a new thread.

For other users who might find this thread, here you can get some context on this issue: How to prevent crypto mining abuse on GitLab.com SaaS | GitLab

Sincerely,
kerel

Is there any other way to validate a user other than by providing credit card details? If there isn’t, then I suspect that in a huge number of cases, we will have to deal with a situation where a new developer joins a team that already has a paid plan at Gitlab, and such a developer must now use his private CC card to be able to work with pipelines.

I’m exactly in this case. I have new developers and I have to ask them their credentials account to set the company credit card.
Could you accept a “group” level credit card allowing all developers within the group to use pipelines

This is crazy. We are deciding on a pretty large contract for which cloud based CI/CD product to go with. GL or a competitor. I’ve been happy with GL 5 years ago. But if this is the level of frustration to TRY PAYING GL to carry out a POC in cloud GL… then it’s just got a very large mark against it already.

Why is the verification not applied at the group level!? The engineers in my team are unable to get around the verify banner to run pipelines against our self hosted or cloud based runners. I don’t expect them to enter their own CC details.

Just wanted to chime in that the onboarding user experience lately hasn’t been very smooth. A new Gitlab user is invited to be a group member via their company email, they notice they are not able to run pipelines, confused why they’re being asked for a credit credit when they were added as a member of a company group. Both resolutions are not ideal:

  • They enter their private card details to GitLab or
  • We share company card details to the new user to enter, this is not ideal either.

Am I missing something cleaner that can be done?