[Solved] Can't install gitlab from omnibus rpm package on Centos 7

Hello, i need help.
After updating to 7.6.2 of my omnibus package i started to get 500 error very often so i decided to reinstall gitlab.
First i deleted it with rpm -e, then installed it but i changed nothing so i decided to remove everything manually. I made gitlab-ctl cleanse and looks liek it removed something but it didn’t help too. So i removed all directories myself:
After that when i try to install gitlab from rpm, it says succesfully installed, but when i do: gitlab-ctl status i shows no processes. Also i checked folders rpm didn’t install anything at all exept some basic configuration files. How can i fix it? Please help.

So, the directories


are empty even after the re-installation? The steps to reproduce according to your issue are:

  1. Update to 7.6.2 from ?
  2. rpm -e gitlab
  3. Install gitlab-7.6.2
  4. gitlab-ctl cleanse
  5. rm -rf /opt/gitlab /var/opt/gitlab /etc/gitlab /var/log/gitlab
  6. Install gitlab-7.6.2
  7. gitlab-ctl status shows no process and dirs are empty

Is that right? I think you missed a step and you didn’t remove gitlab with rpm after step 3.

  1. Update to 7.6.2 from 7.5.1 i didn’t miss any versions since 7.5.?
  2. gitlab-ctl uninstall
  3. gitlab-ctl cleanse
  4. rpm -e gitlab
  5. install gitlab 7.6.2 and i saw no difference so i made rpm -e gitlab then i removed folder from step 5 of your list
  6. install gitlab 7.6.2
  7. gitlab-ctl status shows no process and dirs are empty
    I also tried to install 7.5.3 and 7.5.1 but result is the same.
    (After all of that i made a docker container and then restored backup, so i get error 500 again, it’s probably in db tables, how can i fix it? -offtop)

Yes they are empty, gitlab-ctl tail says no directory found, rpm only installs scripts in /usr/bin or soemwhere so gitlab-ctl works and gitlab-rake works.

Looks like problem fixed in 7.7, it installed perfectly, thank you.