[Solved] Upgrade gone wrong. :\

Hey guys,

Sorry in advance for my poor Linux skills.

So today I saw a tweet that there was an update to Gitlab CE and decided to remote into my home server and fire it off as I normally do once every week or two. Only this time it locked up on the backing up database portion of the upgrade script. I waited a good hour for it to complete and then decided it had died (There are only 3 users and 3 projects on my server atm.) so I forced a reboot.

Long story short sudo apt-get upgrade wouldn’t work until I did an auto remove and removed Gitlab.

After it removed it I rebooted I did a sudo apt-get install Gitlab and waited until that finished. When it was done I fired up the web interface and it looked like everything was still there and happy. Until I clicked on a project and it said: “This project is empty.”

After doing some checking I found that my NAS box that stores all my projects was inaccessible and had come unplugged from the network due to a broken network cable. On my lunch break, I went home from work and replaced the network cable and then tried rebooting my Gitlab server. After doing that and checking again, there were still no contents on the projects pages. :\

I’m guessing I skipped a critical step somewhere after the reinstall? Do I need to chmod some directories again or go through some of the initial setup steps that I did when creating the server? The config still points at my NAS like it used to and I don’t see any real reason why the page would think there’s no project anymore. The files are all there on my NAS in the same directory they used to be in. :\

Anyone have any tips for how I can go about fixing this issue?

I’d restore the whole mess from a backup if I had one but unfortunately I haven’t gone about backing up this machine yet. >.<

Thanks in advance.


Oh I don’t know if this is needed info but I’m running Gitlab CE on Ubuntu 16.04.1 LTS.


Okay… We are good. :smiley: I extracted all the .git folders off my server thinking I was going to have to rebuild each repo. Then after doing that for S&G’s I clicked the “Create empty repo” button and all the files for my repos showed up just fine.


Everything seems to be working great now from what I can tell.

Time to go make a backup I guess! :stuck_out_tongue: