Unable to buy CI minutes for a group

Everything’s seems ok since the “Checkout” page : the “Confirm purchase” button indicate “Confirming” for 1-2 seconds, and the button come back to the “Confirm purchase” state.
No error message, just a “Recaptcha expired.” in the console : retried several times on Firefox & Chrome, hard refresh done, etc.
Any idea?


Same with edge…
Tried with another credit card = same

We’re experiencing the same issue

1 Like

I guess Gitlab doesn’t like money :see_no_evil:

Thanks for reporting this.

I just tested it on my end (Chrome) and it seems to be working.

Do you by any chance have an ad-blocker enabled? Frequently, these may block the captcha from rendering which may be preventing the form from submitting successfully. If so, can you retry with the ad-blocker disabled?

As a FYI, we’re currently investigating a potentially related issue here: https://gitlab.com/gitlab-org/customers-gitlab-com/-/issues/4193

Update: This issue is no longer publicly accessible as we’ve set this issue to confidential as we were discussing some payment configurations / details while we were troubleshooting.

Hey, no adblock/popup blocker/pi hole etc here

Ok, btw your link seems to be broken

Any news? It’s really annoying on our side…

We’ve been able to replicate the error on our side.

The issue I linked above is unfortunately no longer publicly accessible as we’ve set this issue to confidential as we were discussing some payment configurations / details while we were troubleshooting.

Some of our findings so far:

  1. This is only happening on customers.gitlab.com
  2. This is only happening for credit cards that fail Stripe authorization via Zuora
  3. The Stripe Authorization errors (and therefore failed HPM Hosted Payment Method request) are not coming back to the front-end, so the page is just stuck with spinners.
  4. We tested for 2 types of errors, and they behaved differently
    a. Incorrect CVC - this caused the page to be stuck, no errors returned to front-end.
    b. Insufficient funds - this returned the error properly to the front end, page was not stuck.
  5. Everything works fine if the credit card doesn’t fail Stripe authorization.
  6. Recaptcha expired. message shows up because of the time it’s taking for the page in “loading” stage.

The current logic to handle zuora errors is firstly to check the error code is a number (error code info here) and if it isn’t a number, we throw an error.
For server side errors, the error code is returned as unknown which isn’t a number, so an error is thrown but this is not caught anywhere. This is why the page is stuck in loading state because the error.

The short summary is Zuora server side errors are not handled in way which would show the error message on the page and stop the loading state.

1 Like

We’re currently working on a fix for this.

As a temporary work around, if you encounter this problem where the page is stuck in a loading state:

  1. Please reload the page to reset the credit card form from any errors.
  2. Please try using another credit card. We believe this error only occurs when the card encounters an error (i.e. insufficient funds, failed CVC/CVV check, etc)
  3. If it’s still failing, there may hav been too many failed payment attempts. We may need to manually unblock your card in Stripe. Please submit a support ticket for us to look into this: https://support.gitlab.com/hc/en-us/requests/new

Thx for informations.
I’ve hard reloaded the form, tried with 3 different cards, from different banks, master & visa, well checked the CVC, there is funds on it, tried on 2 differents computer… but unfortunately nothing works.

Have you found a turnaround ?

@BCDiploma we implemented a fix for this today. You should no longer be seeing the page be stuck in a loading state and should instead see the actual error being returned.

Can you give it another try? Hopefully the error is descriptive and tells you what issues the payment is encountering.

Tried again, and… fail
With a first card : same behavior than before : the “Confirm purchase” button indicate “Confirming” for 1-2 seconds, and the button come back to the “Confirm purchase” state. When I edit back the billing address and revalidate it, got an error message “[GatewayTransactionError] Transaction declined.authentication_requi - Your card was declined. This transaction requires authentication.” and my bank notifies me a “fraud alert for 1USD FROM GITLAB USA”…

Ok, tried with another card, new private window, same behavior “Confirm purchase” button indicate “Confirming” for 1-2 seconds, and the button come back to the “Confirm purchase” state. GO back, and now [Submit_Too_Quick] Too many submissions. Please retry later. Is this limit reached for a card or for gitlab group ?

It’s hard for us, a lot of time lost and no more CI since 4 days. Is there an alternative way to pay? Paypal? Bank transfer?

Thx for your help

Thanks for retrying. It sounds like the payment form submission is now working, however, you’re now having to navigate through a card error.

From the looks of the error message, it seems like your bank might be blocking the transaction. You may need to call them to allow the transaction from GitLab to go through. We might also be able to unblock it on our side by adding your card to an “Allow List” in Stripe. In order to do this, can you submit a support ticket here? https://support.gitlab.com/hc/en-us/requests/new Please provide the Full Name on the credit card along with a link to this forum post.

1 Like

I made a ticket.
I hope you are right, but please note that I tried again with 2 different cards…
I will keep you informed.

Retried on another computer (never tried on it before) with another credit card with different holder name, same same…

Same problem here. submitted a support ticket already. Tomorrow we are running out of minutes, that would be bad.

@BCDiploma I checked your Zendesk support ticket #287163 and it looks like it’s now resolved.

I’m adding the resolution below in case others also run into the same issue.

It looks like your account has one name in the profile.

Kindly add a second name in your profile as a temporary workaround for known issue we are working on. Here are the steps to add a second name:

  1. Navigate to your account profile settings https://gitlab.com/-/profile
  2. Under Main Settings, Update the Full Name field to have 2 names with a space between the names
  3. Scroll to the bottom and click on Update profile settings (Don’t forget this)
  4. Retry the purchase
1 Like