Unable to login on gitlab.com: "Login failed. Please retry from your primary device and network."

I’m trying to log in at gitlab.com, but am not able to do so.

My username and password are correct (I’ve even tried resetting the password), but I get the following error:

Login failed. Please retry from your primary device and network.


I’ve tried it with and without a VPN connection, on Firefox and Chromium… always the same message.

I recently moved and am indeed using a different network. But I am using the same laptop as before.

Also, I have a secondary account (the one I’m currently using here) with which I am able to login. So it seems like perhaps it’s something specifically about my account that is causing the problem.

I have two-factor authentication set up, but I don’t even get to that step because the error message shows up immediately after entering my username and password.

1 Like

I have the exact same issue and just registered here for this.

I can also log in with another secondary account and I get the same error message as above on my primary account. I also have 2FA enabled but get the error message before the 2FA step even shows up. Even a password reset - which seems to work - didn’t help and I still get that error.
Strangely enough, I didn’t change my network, browser or PC.

Thank you for reporting this @celeste_raspberry and @999eagle . Can you confirm if you saw a captcha and if so if you completed it?

Hi @whaber, I just tried again and didn’t see a captcha.

Thanks for confirming. Please (privately) send me your gitlab user id so we can research further.

@celeste_raspberry @999eagle

Please try logging in again as we made a configuration change a few minutes ago that should resolve this for you.

We have anti-abuse features that we are working on. We are currently tuning for false positives (legitimate users who can’t login) and false negatives (bad actors who can’t login and shouldn’t be able to).

One of the two users who reported an issue has confirmed they can now login again. The other hasn’t confirmed as of yet.


Everything works again, I am logged in again. Thank you very much @whaber and others who helped out with this so quickly!

1 Like

@whaber I’m also seeing this issue. I was trying to figure out how to send you a message directly, but when I click on your username, there’s no envelope logo like the “new message” page seems to say should exist.

There was some page it sent me to before forwarding me on to the Gitlab login page, but there was no captcha. I’ve tried from both my home connection and my work VPN connection - both get the same error.

I’m thankfully able to view public repos, but when I put the URL in wrong the first time and got a 404 it was forcing me to login, so that was less than ideal.

@whaber Hello, I have the same problem. I connect from a laptop and a PC, they are on different WI-FI and LAN networks and different external IP.

Connecting from a PC: Success
Connecting from a Laptop: “Login failed. Please retry from your primary device and network.”

How can I add my laptop to allow list?

@whaber I have the same issue. Two days ago I could log in, but now I can’t using the same computer and network.

@whaber I’m having the same problem.

I’m able to login via my cellphone (Firefox on IOS) but not my laptop (Firefox on FreeBSD). Username is retrohacker.

On my cellphone, I’m presented with a captcha. On my laptop, no captcha and a notice pops up saying:

Login failed. Please retry from your primary device and network.

@retrohacker @raptor2m @EvilSpirit171 @belak

We made some additional changes at around 16:00 UTC today for better tuning of false positives / false negatives.

Please try logging in again.

@whaber Still unable to login, same error.

@whaber I’m also having te same issue. Was able to login once (after many times) but can’t get in anymore

It seems to work for me now. Thanks!

1 Like

Same here. I got this error, then a few 422 errors, now I can login with my home email and password again. Before I could only login using the work github OAuth.

The intermittent login issues today seem to have been caused by a security change we put in place a few hours ago to improve security. We have rolled back the security change in the interim.

Please try logging in again if you had an issue today.

In the interest of our value of transparency, here is the MR we are working on that is believed to be the cause of the intermittent issue: Switch from respond_with_navigational to redirect_to (!85127) · Merge requests · GitLab.org / GitLab · GitLab


Thank you for being so responsive today.

I’m able to login now!

1 Like

first of all check your internet connection health is good or bad.I mean that checked the internet quality then try again to login if not login forget the password check email in inbox. or spam folder.otherwise make new account on github with new gmail id if again issue please used another browser like opera and edge.