"Can create top level group" Checkbox disappeared

The Buck, Error, etc. occurred, when I tried to create a group as a admin on the top level of a blanc Gitlab Server. The create button was nowhere found, so I went in the admin area to do it there. After filling the creation mask, i clicked on the Create group button. I got the notification, that I don’t have the permissions to do that. I tried to create a project too, but here I got just a Error 404 web page, when i clicked on the new project button in the main Manu.

Then I went to the User Management to edit my admin account, I thought i accidentally remove the permission. But to my surprise, the “Can create top level group” permissions was active. After short research I got the tip to upgrade to the newest version of Gitlab. I Upgraded from v16.8.2 to v16.9.0. The behavior was unchanged, but the “can crate top level group” checkbox in the User account mask disappeared… So, now I can’t create any Group or Project on my Blanc Server nor give anyone the permission to do so.

I guess the first responders will suggest: “well, just reinstall it, you got nothing on it yet”. But it is not that simple. My Company is moving from SVN to Git. A very expensive undertaking and I was the one that pushed this for over one Year. Now we finally implemented the new Version control and before we even uploaded the first Repo, an Error brings everything to a standstill, and no one can explain why. This is REALY bad!

Setup:
I installed the GitLab DEB package version 16.8.0 on a Debian 12 (Bookworm) system. Later i upgradet it to 16.8.2. This Debian system is running on a virtual machine. The installation was successful, and everything worked as expected. Subsequently, we created an image of this machine. We then installed the image on another machine, which we refer to as the “Productive Server.” The original machine is known as the “Test Server”. The Image was taken 2 weeks ago.

In the last two weeks i played around with the Test Server to get used to GitLab. Everything worked fine. Yesterday then, I tried to implement the first Migrated Repos to the Productive Server, when I realized, i can’t create top level groups.

I also upgraded the Test Server, which is basically the twin system of the Productive Server, to 16.9.0, and it just works fine. I was not able to reproduce this Error.