Infinite loop checking browser on brave

Hi there,

I’m unable to login with my brave browser. I have no extensions on it (I just use the ad blocker included). What’s strange is: it works on private mode. There is an infinite loop on the page “checking browser”, with a 503 error on the page, and then it reloads. I can see a little iframe poping sometimes, but nothing more.

Console logs errors:

  • Error with Permissions-Policy header: Unrecognized feature: ‘interest-cohort’.
  • Error with Permissions-Policy header: Unrecognized feature: ‘serial’.
  • sign_in:1 GET 503
  • [Deprecation] chrome.loadTimes() is deprecated, instead use standardized API: Navigation Timing 2.
  • [Deprecation] ‘window.webkitStorageInfo’ is deprecated. Please use ‘navigator.webkitTemporaryStorage’ or ‘navigator.webkitPersistentStorage’ instead.

I have run into multiple thread talking about the problem, but no solutions or workaround explained, just “now it works”… One of them tell to put the javascript in step debugging, and it works but not for me. List of threads i read:

Things I tried:

  • disable anything from security settings on the browser
  • allow gitlab for tracker
  • delete all cookies and navigation data
  • factory reset of all parameters of the browser

Without success.

I don’t know since when this issue is active. I can use another browser but that’s really inconvenient. I don’t know if at home I have the same problem. I use Version 1.29.79 / Chromium: 93.0.4577.63 (official build) on a desktop ubuntu mate 20.04.3, UTC+2. In the last link, a lot of people are in Brazil, that’s not my case, i’m in France.

I don’t have the issue on Android Brave browser (connected to the same network). I don’t know what’s going on. Any help is appreciated. I hope it’s just temporary.


If it works on private mode in Brave, then that means there is a plugin or some other function or feature enabled that is causing an issue. Otherwise it wouldn’t work at all in Brave.

You could always reset your Brave browser settings to the defaults. I’ve just logged in with Brave, and works fine. So it must be a setting at your end that is causing the problem.

Yes, I agree about that. But I can’t find what’s the difference between Brave classic settings and Brave private mode settings.

As I said, there is no plugins nor extensions, the browser is really vanilla. I already reset Brave browser settings to the defaults and still not work :confused:

I’m wondering what i’m doing wrong. The only thing I change when I reset settings is the default search engine (back to google instead of qwant), and that’s all. I just double checked, I confirm I have no extensions in the “brave://extensions” page. Could I have some extensions installed not displayed there?

OK, let’s check/compare settings. First screen, check the Brave icon near the URL bar and see if you have the same as below:

1 Like

OK, that’s VERY strange: If I do a new window or a new tab, not in private mode, I don’t get stuck. So it’s like my pinned tab is broken. Could it be possible? Even with a clear of cookies, the pinned tab was stuck.

It seems it was a false alert, I’ll kill my pinned tab and redo a new tab that I’ll pin.

So, if another user has the problem, that’s how I solved it: my problem was only on that pinned tab. :confused:

Thanks a lot iwalker to have take of your time to help me.


There is an option somewhere to do with leaving Brave open in the background. Maybe that might be worth turning off, so that when you close Brave, it does actually close fully, rather than leave a background process. That might help fix the tab issue.


Indeed, the option was turned on. I disabled it just in case.

I just remembered my office PC which had the problem got an electric shutdown this week-end. I closed Brave last friday, but maybe it didn’t fully closed and the tab was corrupted since. Don’t know. But thanks a lot :slight_smile: